Utiliser Symfony 2 avec 1and1

Symfony 2 à besoin de php 5.2.3. Vous devez donc créer/éditer le .htaccess à la racine et y ajouter:
AddType x-mapp-php6 .php
Cela va vous permettre d'utiliser la version php 5.4.0beta1.
Il reste maintenant le problème de timezone, pour cela créez un fichier php.ini dans le répertoire Symfony/web contenant:
date.timezone = "Europe/Paris"
short_open_tag = off
magic_quotes_gpc = off

Maintenant vous pouvez lancer, http://foo/bar/Symfony/web/config.php et vous ne devriez plus avoir de problèmes.
This entry was posted in Uncategorized. Bookmark the permalink.

2 Responses to Utiliser Symfony 2 avec 1and1

  1. Clad says:

    Comment modifier la version de PHP que j’utilise ?
    La version 4 de PHP étant la plus utilisée, chez 1&1 Internet l’extension .php est ainsi prise en charge par PHP4.

    Voici notre schéma de configuration :
    * PHP4 : .php / .php3 / .php4
    * PHP5 : .php5

    Si vous souhaitez utiliser PHP5 avec l’extension .php c’est très simple.
    Créez alors un fichier qui porte le nom .htaccess et placez le contenu ci-dessous

    AddType x-mapp-php5 .php
    Source : http://faq.1and1.fr/scripts/php/5.html

  2. Clad says:

    PHP6 est le futur successeur de PHP5 et se trouve actuellement encore dans l’un des premiers stades de développement.

    Pour pouvoir utiliser PHP6 sur votre espace Web, veuillez créer un fichier .htaccess dans le répertoire souhaité (ou ajoutez-le à un fichier .htaccess déjà existant) avec le contenu suivant :

    AddType x-mapp-php6 .php
    AddHandler x-mapp-php6 .php

    Ainsi, tous les scripts PHP sont traités comme des fichiers PHP6.

    De manière alternative, les scripts dotés de l’extension .php6 sont interprétés automatiquement avec PHP6.

    Remarque:

    Étant donné que PHP6 se trouve encore au stade expérimental, nous ne pouvons pas garantir son fonctionnement correct.

    Source : http://faq.1and1.fr/upgrade/upgradephp/5.html